微擎 — 模块安装,新老版本版权保护问题解决方法

大家在本地搭建及测试时,有时会遇到模块安装时出现,版权保护,未在云平台注册等等一类的问题。现在我将解决方法贴出,与大家分享。不管是新版本,还是老版本,问题解决根本方法是修改微擎内部的cloud.mod.php文件,把对应的代码注释掉。打开根目录下:\framework\model\cloud.mod.php文件

针对老版本:

代码23行:

if(empty($_W['setting']['site']['key']) || empty($_W['setting']['site']['token']))  
     return error('-1', "您的程序需要在微赞云服务平台注册你的站点资料, 来接入云平台服务后才能使用相应功能.") 

代码36行:

if ($dat['content'] == 'install-module-protect')  
              return error('-1', '此模块已设置版权保护,您只能通过云平台来安装。') 

代码151行:

if ($dat['content'] == 'install-theme-protect')  
                return error('-1', '此模板已设置版权保护,您只能通过云平台来安装。');

针对新版本:

代码118行

if(empty($_W['setting']['site']['key']) || empty($_W['setting']['site']['token'])) {
        return error('-1', "您的站点只有在微擎云服务平台成功注册后,才能使用云服务的相应功能。");
    }

代码289行

if ($dat['content'] == 'install-module-protect') {
        return error('-1', '此模块已设置版权保护,您只能通过云平台来安装。');
    }

代码419行

if ($dat['content'] == 'install-theme-protect') {
        return error('-1', '此模板已设置版权保护,您只能通过云平台来安装。');
    }

将以上代码注释掉,或者删除就行了! 
后台皮肤无法使用! 也是同理,均在此文件内修改!

相关推荐

评论 抢沙发

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址